WavPackの再生時間表示がおかしい

フォーラム TuneBrowser WavPackの再生時間表示がおかしい

このトピックには25件の返信が含まれ、3人の参加者がいます。2 日、 20 時間前 Tiki さんが最後の更新を行いました。

26件の投稿を表示中 - 1 - 26件目 (全26件中)
  • 投稿者
    投稿
  • #6838

    pinky
    参加者

    一時停止後に再生すると次曲に移るときに画像のように青っぽいアンダーバーが下に移らないで再生時間も加算されてしまう

    画像では6の再生中に一時停止、再生すると次に移るときに曲自体は次曲7が再生されるがアンダーバーは移下に行かないで再生時間も3:55/3:20になり、最後の曲まで加算されていく

    一時停止しなければ問題ない

    ファイルはWavPack、他のファイルでも試したが同じ現象が起こる

    http://pd.kzho.net/1569686975206.jpg

     

    Attachments:
    #6840

    pinky
    参加者

    追記

    バージョンは4.11.5

    前のバージョンでも同じ

     

    #6841

    Tiki
    キーマスター

    こんにちわ。ご連絡ありがとうございます。

    念のため、手許の環境で確認をしてみましたが、再現させることができませんでした。

    ファイルはWavPack、他のファイルでも試したが同じ現象が起こる

    ここで、「他のファイル」と言われているのは、FLACなどほかのファイル形式という意味でしょうか? あるいはWavPack形式の他のファイルという意味でしょうか? 後者の場合、ほかのファイル形式の場合は、いかがでしょうか?

    #6842

    pinky
    参加者

    「他のファイル」は同じWavPack形式という意味です

    多く試しましたがすべて同じ現象が出ますのでファイルの不具合ではなさそうです

    foobar2000では問題ありません

    他の形式はMP3では現象発生せずです

    #6843

    pinky
    参加者

    追記

    flacも試しましたが問題有りません

    WavPackだけのようです

    #6844

    pinky
    参加者

    「一時停止と再生」は一時停止で解除して再生ではなく、一時停止してから再生をクリックの事です

    一時停止だけで一時停止と一時停止の解除をした場合は問題は出ないですね

    やっていることは同じだと思ったのですが、動作に違いはあるのでしょうか?

    なぜWavPackだけかは疑問ですが

    #6845

    Tiki
    キーマスター

    追加の情報ありがとうございます。

    WavPack形式だけで発生していること、一時停止クリック->再生クリックで発生するとのこと、了解しました。

    あらためて試してみましたが、やはり再現しません。他の方からのご連絡も待ってみましょうか。情報を得やすいように、タイトルを変更しますね。

    #7137

    Kou
    参加者

    同じようにWavpackで一時停止→再生で症状が発生します。

    Attachments:
    #7139

    Kou
    参加者

    pinkyさんと同じですが

    一時停止→一時停止をクリックで解除:問題なし

    一時停止→再生をクリックで解除:問題発生

    Ver4.12.0です。

    #7164

    Tiki
    キーマスター

    こんにちわ。

    追加の情報ありがとうございます。やはりWavPack以外では発生しませんか?

    #7205

    Kou
    参加者

    AAC,flac,MP3,Waveでは発生しませんでした。

    #7214

    Tiki
    キーマスター

    こんばんわ。

    質問が散発的になってすいません。WavPack形式は、すべてのファイルで同様の状況になるのでしょうか?

    すべてではない場合、特定のファイルのみで発生するのでしょうか? あるいはランダムに起こるのでしょうか?

    特定のファイルの場合、なにかそのファイルについてお気づきの点はありませんか?

    #7225

    Kou
    参加者

    アルバム4つほどで試してみましたが、一時停止→再生で100%発生しました。

    いずれもEAC + EasyWavPackで作成しました。

    #7246

    Tiki
    キーマスター

    こんばんわ。

    お手数をおかけします。

    EasyWavPack 2.6を使用して、WavファイルからWVファイルを作成して、一時停止→再生をクリックで解除してみました。が、やはり問題は確認できませんでした。謎です…。

    #7364

    pinky
    参加者

    わたしもkouさんと同じ環境で作成しています

    EasyWavPack 2.6で単曲ではなくEACでアルバムをWavPackの1ファイルにまとめないと検証にはならないかと思いますよ

    #7365

    Tiki
    キーマスター

    EasyWavPack 2.6で単曲ではなくEACでアルバムをWavPackの1ファイルにまとめないと検証にはならないかと思いますよ

    そうなのですか。そうお考えになる理由を教えていただけませんか?

    #7367

    pinky
    参加者

    EACを使いWavPackでかためてある拡張子wvのアルバムを再生して「一時停止→再生」と操作

    次曲に移ると曲自体は次曲に移行しているのに、曲の下のアンダーバー?は次曲に移行しないで再生時間も前曲に加算されていくという症状です

    あれから数十アルバムのwvファイルを再生してTESTしましたが再現率100%です

    FLACは問題ありません

    私の説明も悪いのかと思いますが、やってみれば再現できると思います

    Kouさんもアルバムと言っています

    参考画像もKouさんはスピッツのアルバム「CYCLE HIT 1991-1997 Spitz Complete Single Collection」でしょう

    私の画像はフレデリックのアルバム「フレデリズム2」です

    EACでWavPackにしたwvファイルは解凍するとwavとcueが出来ます(アルバム画像があればそれも)ので単曲を連続再生するのとは挙動的にどうなのでしょう?

    理由をあまり聞かれても専門家ではありませんのでこれ以上はなんとも言えませんが

    Kouさんと私は「EAC+EasyWavPackでアルバムをwvにしたファイル」を再生した時という同じ条件ですので、違うことをやれ再現は出来ないと思うのは間違いでしょうか?

    #7368

    pinky
    参加者

    wavpack再生で曲が切り替わっても、曲名や再生時間が切り替わらない

    Kouさんが2019-4-28にも同じ報告をあげられていますね

    #7375

    Tiki
    キーマスター

    こんばんわ。

    教えていただいてありがとうございます。

    Kouさんもアルバムと言っています

    このアルバムという言葉から、pinkyさんとKouさんのご利用状況を洞察するのは、わたしには無理でした。ですので、

    Kouさんと私は「EAC+EasyWavPackでアルバムをwvにしたファイル」を再生した時という同じ条件ですので、違うことをやれ再現は出来ないと思うのは間違いでしょうか?

    との最後のご質問については、大変恐縮ながら間違いだとお考えいただかざるを得ないと思います。これまで書いていただいた操作は、環境を用意してすべて再現を試みています。アルバムもEACでリッピングしています。ただ前のコメントで書かれていた「WavPackの1ファイルにまとめないと」という状態にはなっていません。トラック数分のファイルになっています。

    WavPackの1ファイルにまとめる方法については、これまでやったことがありませんので、また後日やり方を調べて再現を試みてみます。

    #7380

    pinky
    参加者

    おっしゃっている意味がよくわかりませんが、正確に伝わっていなかったという点は理解できました

    WavPackはFLACのように1枚のアルバムをフォルダ形式にしないで全曲を謂わばISOのように1ファイルに固めることが出来るのが利点で使っている方が多いと思いますのでTikiさんに於かれましても当然そのような認識だと思っていました

    説明不足になった点をお詫びいたします

    実用上は問題のないものですので私的にはそのままでも結構ですよ

    #7384

    Tiki
    キーマスター

    ご丁寧に恐れ入ります。

    言い訳ではありますが、日々わずかな時間のなかでフォーラムの対応をしておりますので、応対に丁寧さが欠けていて申し訳ないです。

    それで、問題の事象ですがおかげさまで再現させることができました。WavPackの問題というよりは、一時停止→再生(一時停止の再操作ではなく)の操作において、内部の状態の管理に不備があり、結果としてデコーダの種類・状態によって曲の切り替わりが認識できない(CUESHEET方式の場合は次の曲に突き抜ける)ことがあるようです。

    ほかの件とあわせて、近日中に対処できるようにしたいと思います。よろしくお願いします。

    #7392

    Tiki
    キーマスター

    こんにちわ。

    先ほど、この件について対処した先行版(4.12.3)をリリースしました。お手数ですが、お時間のあるときにご確認いただけるとありがたいです。

    よろしくお願いします。

    #7399

    pinky
    参加者

    先行版4.12.3で問題ないことを確認しました

    対応ありがとうございます

    #7402

    Tiki
    キーマスター

    こんばんわ。

    ご確認、ありがとうございました。

    #7418

    Kou
    参加者

    遅ればせながらこちらの環境でも先行版4.12.3で問題なく再生できました。

    これでより快適に音楽ライフを送ることが出来ます。

    ありがとうございます。

    #7421

    Tiki
    キーマスター

    ご確認、ありがとうございました。

26件の投稿を表示中 - 1 - 26件目 (全26件中)

このトピックに返信するにはログインが必要です。