AACの曲の次にFLACを再生するとFLACの最初にノイズが入る

フォーラム TuneBrowser AACの曲の次にFLACを再生するとFLACの最初にノイズが入る

  • このトピックには16件の返信、3人の参加者があり、最後にTikiにより1ヶ月、 1週前に更新されました。
17件の投稿を表示中 - 1 - 17件目 (全17件中)
  • 投稿者
    投稿
  • #8348
    serenity
    参加者

    おはようございます。

    (プレイリスト上で)AACの曲を再生し、その曲が終了して、連続で次にFLACを再生するとFLACの曲の冒頭に「ピッ」というノイズが入ります。

    ・再現性は100%です

    ・ASIOでもWASAPIでも入ります。

    ・同じm4aでもALAC→FLACはノイズが出ません。

    ・AAC→DSFも問題ありません。

    ・FLAC→AACも問題ありません。

    ・Windowsの再起動、DACの再起動をやってみましたが変化ありません。

    Windows10 x64、TuneBrowser 4.15.0 AVX2、DAC:TEAC UD-505

    ノイズが出た部分の音声を添付します(スマートフォンの録音で、音質は悪いです)

    #8350
    serenity
    参加者

    ファイル添付がうまくいかないのでダウンロード先のリンクを貼ります。(リンクの挿入ができないのでそのままです)

    http://sakura.my.coocan.jp/test/AAC%20to%20FLAC.zip

    #8351
    Tiki
    キーマスター

    こんにちわ。

    ・再現性は100%です

    これは、特定のAACのファイル、あるいは特定のFLACファイルの間では100%発生するという意味でしょうか?

    あるいはどんなAACのファイル / FLACファイルの組合せでもかならず発生する、という意味での100%でしょうか?

    #8357
    serenity
    参加者

    Tikiさん、回答ありがとうございます。

    情報不足ですみません。5~6種類で試した範囲で同じく起きました。100%というのは言い過ぎかもしれませんが、5~6種類で試した結果を100%と解釈しました。

    #8359
    Tiki
    キーマスター

    こんにちわ。追加の情報ありがとうございます。

    前回のコメントのときに念のためわたしの環境でも試したところ、ノイズは確認できませんでした。

    おそらく、ですが、お手持ちのAACかFLACのどちらかの楽曲にDC成分が含まれていて、あるいは無音で開始/終了していなくて、曲の切替りのときにその差分がノイズとなって現れているのではないかと想像しています。

    TuneBrowserは変調方式とサンプルレートとチャンネル数が一致したトラックは、形式にかかわらずギャップレス再生を行います。DSD<>PCMは変調方式が異なるので、ギャップレス再生は行わず、一度デバイスを止めて、再設定してから再開します。それで、機器によってはノイズは抑え込まれます。

    複数の種類のファイルで発生しているとのことですが、なにかそのあたりでお心当たりはありませんか。

    また他の方で同様にAAC→FLACに限ってノイズが発生している方はおられますか? > ALL

    #8362
    Tiki
    キーマスター

    こんにちわ。

    考えてみれば、つながるはずのない可逆圧縮と不可逆圧縮のあいだでギャップレス再生を行っていることがまちがいのような気がしてきました。TuneBrowserのギャップレス再生の可否の判定は、上のコメントに書いたように、デバイス側の条件が変わらなければ実施するようにしていましたが、ここにデコーダー側の条件も判定に加えるようにしたほうがよいのかもしれません。

    ちょっと検討してみます。

    なにかこれに関してご意見があれば、お願いします > ALL

    #8366
    serenity
    参加者

    Tikiさん、情報ありがとうございます。

    変調方式や可逆不可逆の問題とDCオフセットの問題は別だと思いますが、とりあえず、現在のプレイリストにある曲についてはXRECORD3でAACをWaveに変換したところ、切換時のノイズは出なくなりました。FLACの方はそのままです。

    AACについては(試したものは) moraからダウンロードしたものが4つ、かなり前にiTunesでAACにリッピングしたものが2つでした。

    #8367
    yellow_hs
    参加者

    Tiki様、はじめまして。TuneBrowserを使わせていただいております。

    この件ちょっと試してみたところ、私の環境でもある条件において発生しました。状況は以下の通りです。

    (1)mp3やAACの圧縮音源→FLAC、ALACの「ハイレゾ音源」 のときに、

    ・WASAPIかつリサンプリングがONの状態で「ビッ」という音がなる。

    ・WASAPIかつリサンプリングがOFFではノイズはならない。

    ・ASIOの場合はリサンプリングON/OFFのどちらもノイズはならない。

    (2)mp3やAACの圧縮音源→FLAC、ALACの「44.1kHz音源」のときは、ノイズは出ない。

    Windows10 Home 64bit

    TuneBrowser AVX2 4.15.0

    DAC アミュレック AL-38432DS

    以上、ご参考になれば幸いです。

     

    #8368
    Tiki
    キーマスター

    yellow_hsさん、こんばんわ。情報ありがとうございます。

    (1)の状態での、

    • リサンプラ―の設定
    • mp3やAACのサンプルレート(44.1か48だと思いますが…)
    • FLAC/ALACのサンプルレート

    について、教えていただけないでしょうか?

    #8372
    yellow_hs
    参加者

    Tiki様、

    昨晩確認したときの条件は
    ・リサンプラー設定:x4
    ・mp3,AAC:44.1kHz
    ・FLAC/ALACのサンプルレート:96.0kHz
    でした。

    先程手持ちのハイレゾFLACの48.0kHz、88.2kHz、96.0kHzで、リサンプラー設定を変えて試してみました。結果は以下の通りで、×のときに「ビッ」「ブッ」という音が出ました。(AACは44.1kHz)

    48.0kHz 88.2kHz 96.0kHz
    Base OK OK OK
    Basex2 OK × ×
    Basex4 × × ×
    Basex8 × × ×
    x2 × × ×
    x4 × × ×
    x8 × × ×
    44100Hz OK OK OK
    48000Hz OK OK OK
    88200Hz × × ×
    96000Hz OK OK OK
    176400Hz × × ×
    192000Hz × × ×
    352800Hz × × ×
    384000Hz × × ×
    705600Hz × × ×
    768000Hz × × ×

    このとき、WASAPI条件のEVENT/PUSH、EXCL/SHARで変化ありませんでした。リサンプラー設定は添付画像の通りです。

    Attachments:
    #8374
    Tiki
    キーマスター

    ありがとうございます。お手数をおかけしました。

    ご指摘のリサンプラ―を使用したケースについて、わたしも今朝から調べていて、ひとつ問題を発見しました。元のデータ型がFLT(浮動小数点)だった場合に、曲の末尾で遅延分のデータをフラッシュするときに、そのフラッシュ分のデータ型を誤って、結果としてノイズになってしまうケースがありました。

    さっそく対処とリリースを… といきたいところなのですが、4.15.0が安定してそうだったので、大きめの改修を複数走らせてしまっています。その痕跡を消してからリリースすることになりますので、すこし時間がかかりそうです。

    #8375
    Tiki
    キーマスター

    「元のデータ型がFLT(浮動小数点)だった場合」というのは、MP3やAACなどの不可逆圧縮系がそれに該当します。

    #8376
    yellow_hs
    参加者

    Tiki様、

    既に問題点を発見されたとのことですので蛇足になりますが、176.4kHzのFLACを追加し、今度はASIOでAAC 44.1kHzからリサンプルした場合を調べてみたところ、以下のようにASIOでもノイズが発生していました。昨晩はたまたまノイズが出ない組み合わせだったようです。ーはDAC未対応のレートです。

    48.0kHz 88.2kHz 96.0kHz 176.4kHz
    Base OK OK OK OK
    Basex2 OK × OK ×
    Basex4 OK × OK ×
    Basex8 OK × OK ×
    x2 OK OK OK OK
    x4 OK OK OK ー
    x8 OK ー ー ー
    44100Hz OK OK OK OK
    48000Hz OK OK OK OK
    88200Hz × × × ×
    96000Hz OK OK OK OK
    176400Hz × × × ×
    192000Hz × × × ×
    352800Hz × × × ×
    384000Hz × × × ×
    705600Hz ー ー ー ー
    768000Hz ー ー ー ー

    44.1系と48.0系で違いが出ていました。これが仰っているデータ型によるものなのか、当方のDACとの相性なのか私には判断できませんが、ご参考になれば幸いです。

    #8377
    Tiki
    キーマスター

    追加の情報ありがとうございます。お手数をおかけしました。m(__)m

    参考にさせていただきます。

    #8426
    serenity
    参加者

    4.15.1 先行版を早速インストールし、いくつかの「AAC→FLAC」連続再生を試してみてノイズが出ないことを確認しました。対応ありがとうございました。

    リサンプル後のサンプルレート:768000 Hz

    このレート以上は変換しない (Hz):882000

    でテスト

    #8427
    yellow_hs
    参加者

    Tiki様、
    私の環境でも4.15.1 AVX2 64bit版でノイズが出ないことを確認いたしました(WASAPI, ASIOとも)。
    どうもありがとうございました。

    #8433
    Tiki
    キーマスター

    さっそくご確認下さり、どうもありがとうございました。

    改善して、よかったです(^^)

17件の投稿を表示中 - 1 - 17件目 (全17件中)
  • トピック「AACの曲の次にFLACを再生するとFLACの最初にノイズが入る」には新しい返信をつけることはできません。