Random glitches during playback

フォーラム TuneBrowser Random glitches during playback

  • このトピックには20件の返信、2人の参加者があり、最後にTikiにより6日、 3時間前に更新されました。
21件の投稿を表示中 - 1 - 21件目 (全21件中)
  • 投稿者
    投稿
  • #13056
    WanFie
    参加者

    First of all congratulations for this wonderful software. This really sounds way better than anything I’ve tried before (including JRiver). But unfortunately it doesn’t work here without interruptions. Sometimes it plays 6 hours straight without a glitch, But today unable to listen undisturbed for half an hour. JRiver plays on the same PC and the same conditions without interference. I have already tried many settings, but still having problems. First I played with version 5.2.1. now with the advanced version 5.2.2. I also installed the UWP version, but unfortunately it was not error-free there either.
    So the current installation is 5.2.2. free edition, I would like to pay, but then it has to work. I use the software exclusively with BubbleUPnP as a controller and music from Qobuz.

    Sorry, I live in the Netherlands and don’t speak Japanese. Therefore in English.

    #13058
    Tiki
    キーマスター

    Thank you for finding TuneBrowser out of all the music software available.

    Do you see any errors when playback stops? If so, please attach a screenshot of it here.

    Also, by default, TuneBrowser stops playback on an album-by-album basis except in Playlist. Please check this setting.

    • TreeItem: Playback settings
    • Property: Playback operation and confirmation – Playback selected albums

    Thanks

    #13059
    WanFie
    参加者

    Thank you for the quick answer.
    No, there are no error messages on the screen. I have set the suggested setting to “no”, but played too short to give a result.
    It’s not that I use a very long playlist, but select every album and usually listen to it in its entirety.
    That sometimes goes 5 albums in a row without a malfunction, but it can also go wrong with the first album and the first track. Usually the music starts playing again after a short or longer period of time. Short is within 5 seconds, long is sometimes even after 5 minutes. It is also difficult to pinpoint where the problem is. Is it TuneBrowser or is it Qobuz or our internet provider. I never had the problem with my previous player, but the whole song was loaded into memory. This is a setting in JRiver.
    I found TuneBrowser on the Audiophile Style Forum. And it really is the best sounding. Resonance of instruments and naturalness of sound are extremely good. Micro information is passed on very well. Much better than Roon, JRiver and for example Audiophile UPnP Renderer. I also tested Volumio and a lot of other Linux players, but they often had problems with the software of my Pink Faun i2s sound card. However, this works perfectly with TuneBrowser under Windows 11.
    Troubleshooting now….

    #13060
    WanFie
    参加者

    Hello Tiki, during a malfunction that lasted a little longer, I saw that the yellow DECD square lit up.
    Settings now:
    use RAMdecode is no
    RAM decode mode is by each tune
    Maybe this solves something?

    #13061
    Tiki
    キーマスター

    Hello,

    If DECD indicator is lighting, waiting stroage while reading file is occuring. So there is a possibility to solve this wating by using RAMDecode.

    And also, you can adjust (increase) buffer size insted of RAMDecode.

    – TreeItem: Playback settings – Decoding
    – Property: File accessing – Memory cache size (KB) for reading file

    #13062
    Tiki
    キーマスター

    What type of storage are you using ?

    #13063
    WanFie
    参加者

    Thanks again. I will try.

    I use a 128 Gb Kingston SSD for Windows 11 and Tunebrowser. 8Gb RAM and music streaming from Qobuz.

    It is a self-built streamer that is only used for playing music on a high-quality audio system.

    The motherboard is an AsRock J5005 ITX and I’m trying to build as high quality as possible but also a low power system. TuneBrowser helps me a lot with this.

     

    #13064
    WanFie
    参加者

    Unfortunately, no real solution. Yesterday it played fine for hours. This morning an album stopped after a few songs. Now with the comment “Loading files 0%”. After pressing pause and play, the music started again.

    Attachments:
    #13066
    Tiki
    キーマスター

    Thank you for tring.

    Then, are your music files stroed in Qobuz (not local drive) ? And, is TuneBrowser reading files from Qobuz via a stream like http?

    Unfortunately, TuneBrowser is not supporting Qobuz. And Qobuz is not starting service in Japan. So I can not test it.

    #13067
    Tiki
    キーマスター

    If you are playing Qobuz steaming by TuneBrowser, I think you are using other app to browse tracks because TuneBrowser is not supporting Qobuz. And also I think that TuneBrowser is running as a player (renderer) only. Is it correct ?

    #13068
    WanFie
    参加者

    Thank you very much for the quick replies. This helps me a lot.
    I use BubbleUPnP as UPnP controller. It can send Qobuz files to any UPnP renderer. Tidal is also possible with BubbleUPnP. But streaming the TuneBrowser library also works very well.
    Earlier I played with BubbleUPnP to JRiver. That always worked without any problems. However, TuneBrowser sounds much better.
    After the settings you have suggested, malfunctions are virtually non-existent. So today only received that Fileloading notification once.
    I actually use TuneBrowser headless (without the use of the monitor). I put TuneBrowser in Windows 11 startup. And I close with the button on the PC.
    Do you think the problem of “Fileloading” is in the network, or at least before the streamer?

    #13069
    WanFie
    参加者

    Indeed, I mainly use TuneBrowser as a UPnP renderer. But I also have 60,000 tracks on a NAS. I now organize this with JRiver (modify tags and such). But actually want to do this with TuneBrowser. That’s why I also want to go to the pro version.
    BubbleUPnP is very suitable for streaming music from Qobuz or Tidal.

    #13070
    Tiki
    キーマスター

    Thank you for your explanation. My understanding of the situation has improved much.

    BubbleUPnP is a little bit difficult. Some cases are reported in this this forum.

    Can you send me a dumpfile when the problem occured ? When you faced to the problem, please keep TuneBrowser running (don’t quit TuneBrowser) and select a menu at the top of TuneBrowser, “Help” – “Dumpfile” – “Generate dumpfile for inspection”.

    Then, dialogbox will be shown to generate dumpfile, and please enter “the code” below:

    391B-022E

    This code is valid for 3 days. Please do not panic. If more than 3 days have passed and you need to get a new code, I can recreate it.

    #13071
    WanFie
    参加者

    I have sent a dump file. This was a short disruption.

    #13072
    Tiki
    キーマスター

    Thank you. I’ve received dumpfile.

    And, log contents show that socket session was disconected by the server.
    Unfortunately, I cannot determine reason…

    2023/01/12 20:22:16,857: T00fb0: TL17: TGHttp: HTTP Connect : [http://192.168.2.xx:xxxxx/proxy/qobuz/5F219AB99CA9399C5F0DAD293D4BCAB9.flac]
    2023/01/12 20:22:16,861: T00fb0: TL17: TGHttp: File size is already determined: 12840013 bytes
    2023/01/12 20:22:16,863: T00fb0: TL17: TGHttp: HTTP Get : From: 0 Size: 4194304
    2023/01/12 20:23:09,841: T00fb0: TL17: TGHttp: HTTP Get : From: 4194304 Size: 4186424
    2023/01/12 20:24:01,265: T00fb0: TL17: TGHttp: HTTP Get : From: 8380728 Size: 4194264
    2023/01/12 20:24:52,249: T00fb0: TL17: TGHttp: HTTP Get : From: 12574992 Size: 265021
    2023/01/12 20:24:52,250: T00fb0: TL17: TGHttp: HTTP Receive failed: [TFXFWSocketDisconnected]
    #13073
    Tiki
    キーマスター

    I’ve just found second dumpfile. Thanks again.

    It shows timeout caused. Server did not not send data within 5 seconds.

    2023/01/13 11:43:01,862: T0192c: TL17: TGHttp: HTTP Get : From: 4194304 Size: 4186522
    2023/01/13 11:43:34,575: T0192c: TL17: TGHttp: HTTP Get : From: 8380826 Size: 4194288
    2023/01/13 11:43:39,617: T0192c: TL17: TGHttp: HTTP Receive failed: [TFXFWTimeout]

     

    You can adjust this 5 seconds (=5000 ms).
    – TreeItem: Basic – Network
    – Property: HTTP file access – Receive timeout to begin (ms)

    #13074
    WanFie
    参加者

    And thanks again for the answer.
    I have changed the cache size, to 4096 and 2048 Kb. Buffer time increased to 10,000 ms, but unfortunately still interrupts. I now know that it is in the communication between Qobuz and TuneBrowser. I also used another somewhat older tablet for operation. Unfortunately no improvement either.
    This morning already three short interruptions within an hour.
    I now suspect our ISP’s router. Internet comes here via fiber optic (200 / 200 mbps). This type of router seems to cause problems more often. I will contact our internet provider for a solution.
    Thanks again for your support and I’ll keep trying to get TuneBrowser working. It really is a top product.

    #13076
    WanFie
    参加者

    It seems that I have found the causes. First of all it turned out to be necessary to reset the modem. After that, all my carefully set static IP addresses were gone. But there were still a few in the wrong range left. So they were fixed in the device in question and not in the modem.
    The second problem was in my Android tablet. That automatically connected to a Wi-Fi point further away. This happened during the access point reboot on my set. When the much better Wi-Fi point was active, it hangs on the weaker Wi-Fi point.
    The modem has therefore been reset and provided with the correct static IP addresses. I replaced the Tablet with an Android 11 tablet that will only be used for the set. TuneBrowser is now Ramdecode off and 256 kB cache.
    I haven’t had any problems since these changes. I hope it stays this way.
    Thanks again for great service.

    #13081
    Tiki
    キーマスター

    Thank you very much for your detailed exploration and report. It seems understandable why the problem occurs rarely if it is caused by the network environment.

    I hope this has solved the problem.

    Thanks again !

    #13126
    WanFie
    参加者

    I now have the paid version. There have been a few small and short interruptions, but no longer disturbing. I still have to solve a few other little things, but that is because I am probably very perfectionist.
    For now, TuneBrowser is the best working and more importantly the BEST SOUNDING player I’ve ever used. Earlier I compared a lot of music players together with other users. Including JRiver, Roon, HQplayer, Foobar2000, Audiophile UPnP renderer etc.
    Mr Tiki, thank you very much!!

    #13130
    Tiki
    キーマスター

    Thank you for sending follow-up report.

    And I’m very happy that you agree that TuneBrowser is a good music player. It was worth the effort to continue the development. Thanks again for your kind words.

21件の投稿を表示中 - 1 - 21件目 (全21件中)
  • トピック「Random glitches during playback」には新しい返信をつけることはできません。