asio利用時の解放処理について

フォーラム TuneBrowser asio利用時の解放処理について

  • このトピックには4件の返信、2人の参加者があり、最後にdaiにより4ヶ月、 1週前に更新されました。
5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #11696
    dai
    参加者

    こんにちは。

    Tunebrowserの有償版を便利に使わせていただいています。

    ご相談なのですが、Tunebrowserを終了時に、自動的にwasapiへ切り替えて無音サウンドを

    再生してからASIOに戻して終了するようなオプションはつけられないでしょうか?

    TuneBrowser終了時のASIO解放について

    こちらでも議論されていますが、私の環境だと、ドライバをASIOにしていると、

    TuneBrowserで再生後に、アプリを終了しても、ほぼ2回に1回位は

    ドライバの解放が行われず、Tunbrowser以外の音声が再生されなくなっていしまいます。

    このフォーラムを参考にして、再度tunebrowserを開いて、wasapiに切り替えて適当な

    楽曲を再生してから、終了すると別アプリで音声再生できるのですが、正直かなり不便です。

    フォーラムだとドライバの問題であり、Tunebrowserでの対処は難しいとなっていましたが、

    対処療法的に、解消の手順(wasapiでの再生)をtunebrowser側で自動処理していただくわけには

    行かないでしょうか?

    あまりに、泥臭すぎますかね?

    常時wasapiで使えば良いのかもしれませんが、せっかくtunbebrowserを使用するのなら

    是非ASIOで使いたいので。

    環境)Windows10+Tunbrowser5.1.1AVX2バージョン

    #11697
    Tiki
    キーマスター

    こんばんわ。

    古い議論まで調べていただいて、ありがとうございます。あらためて読み返してみましたが、TuneBrowser以外のアプリでも発生する事象ということで、ドライバの問題という整理になっていましたね。

    正直なところ、ご要望いただいたような対処はちょっと厳しいです。ちなみに、どのようなDACをご利用でしょうか? やはり前のトピックで話題に出たような機種なのでしょうか?

    #11698
    dai
    参加者

    こんにちは。

    私が使用しているのは、ifiのZendac V2をFirem V7.03cで使用しています。

    それなりに有名な機種だとは思いますが、歴代のトピックではでていませんでしたね。

    恐らく、ブラウザとしてchromiumを使用して、youtubeを見る事が多いせいだとは

    思うのですが、TubBrowserを使用後に音が鳴らなくなることが多く、その度に、再度

    立ち上げなおして、wasapiに変更→適当な曲を一瞬再生→終了というのをやっているので

    結構大変です。他にも同様に困っている人もいるかと思ったので、自動で処理してくれれば

    楽だなと思ったのですが、やはり難しいですかね。

    #11699
    Tiki
    キーマスター

    こんばんわ。

    また別の機種でも発生しているのですね…。ご要望の機能はやはりちょっと実現はさまざまな意味で厳しいと思うのですが、前回の議論からしばらく時間がたっていますし、新鮮な目でもうすこしなにかできることがないか、考えてみます。

    #11701
    dai
    参加者

    こんにちは。

    何とかなると嬉しいですね。

    今だと、TuneBrowserで音楽再生。→終了→次にゲームをやろうと起動。→音が鳴らない。

    と来て、そういえばTuneBrowser使ってたっけ。と気づいて、

    ゲーム終了→再度TuneBrowser起動→設定をwaspiに変更→適当な音楽再生→asioに設定を戻す→

    TuneBrowser終了→ゲーム起動

    みたいなことを結構頻繁に繰り返しています。

    それでも、ここの過去トピックで、一度TuneBrowserでwasapiで再生すると、解放処理できると

    分かって、大分楽にはなりました。それまで原因が分からずに、OS再起動してました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • このトピックに返信するにはログインが必要です。