ビューに何も表示されないことがある

フォーラム TuneBrowser ビューに何も表示されないことがある

  • このトピックには17件の返信、3人の参加者があり、最後にTikiにより3ヶ月、 3週前に更新されました。
18件の投稿を表示中 - 1 - 18件目 (全18件中)
  • 投稿者
    投稿
  • #9683
    serenity
    参加者

    こんにちは。

    頻度は多くないですがタブを切り替えた時、時々アルバムビューに何も表示されないことがあります。プレーヤービューはそれまでの表示がそのまま表示されています。

    音楽ファイルは大きいサイズが多いですが、小さいサイズでも起きます。その時エクスプローラーでファイルがある場所を開いても問題なく開けます。TuneBrowserを一旦終了し、再度起動すると問題なくTuneBrowserにも表示されるようになります。最近起きるようになりました。

    アVX2 Version 4.17.2.1555

    #9695
    Tiki
    キーマスター

    こんばんわ。ご報告ありがとうございます。

    そのような事象はわたしのところでは起きたことがありません。言われている通りのことが起きているのでしょうが、念のため、もし次に発生した場合、そのスクリーンショットをアップしていただけないでしょうか。

    よろしくお願いします。

    #9696
    serenity
    参加者

    Tikiさん、ありがとうございます。

    あれからまだ一度も起きていません。起きましたらスクリーンショットをアップいたします。

    #9702
    serenity
    参加者

    おはようございます。

    アルバムビューになにも表示されない状態が再現しました。再起動ではなく、一旦タブを閉じてからそのプレイリストを選択したところ、正常に表示されました。

    画像1:表示できなかった状態

    画像2:正常に戻った状態

    Attachments:
    #9705
    Tiki
    キーマスター

    serenityさん、ありがとうございます。

    1.のときのタブは、Tree Viewなどから新たに開いたときに空で表示されたということではなくて、起動時からあるものでしょうか?

    それがYesだとして、このなにも表示されていないタブは、起動時からアクティブ(全面)に表示されていたものでしょうか、あるいは起動時にはべつのタブがアクティブになっていて、このタブをクリックしてアクティブにしたら、空で表示されたというような感じでしょうか?

    ちょっと質問がわかりにくいかもしれませんが、そのときにはまた言っていただけますか。よろしくお願いします。

    #9706
    serenity
    参加者

    Tikiさん、ありがとうございます。

    1.のときのタブは、Tree Viewなどから新たに開いたときに空で表示されたということではなくて、起動時からあるものでしょうか?

    起動時ではないです。タブを切換えていった時にそうなったものです。

    あるいは起動時にはべつのタブがアクティブになっていて、このタブをクリックしてアクティブにしたら、空で表示されたというような感じでしょうか?

    まったくその通りです。

    よろしくお願いいたします。

    #9707
    Tiki
    キーマスター

    起動時ではないです。タブを切換えていった時にそうなったものです。

    細かいですが、「タブを切換えて」いくことができたということは、そのタブは起動時からアクティブではない状態で表示されていたということでしょうか。

    また、よく見ると、タブのアイコンから1はデータベースプレイリスト、2は内部プレイリストファイルですね。1と2は両方ともTree Viewに表示されているのでしょうか?

    #9708
    serenity
    参加者

    細かいですが、「タブを切換えて」いくことができたということは、そのタブは起動時からアクティブではない状態で表示されていたということでしょうか。

    他の正常なタブに切り替えた時に突然現れた感じです。

    また、よく見ると、タブのアイコンから1はデータベースプレイリスト、2は内部プレイリストファイルですね。1と2は両方ともTree Viewに表示されているのでしょうか?

    ツリービューには内部プレイリストファイルのひとつしかありません。

    「Berliner Philharmoniker – Symphonic Dances」

    #9709
    Tiki
    キーマスター

    serenityさん、何度もすいません。

    なにも表示されないのは、空のデータベースプレイリストが表示されたからで、その後同名の実在する内部プレイリストファイルを表示したら(空ではないので)表示された、という感じのようですね。

    問題はなぜ空のデータベースプレイリストが表示されたのか、ですが、

    他の正常なタブに切り替えた時に突然現れた感じです。

    最初は表示されていなくて、他のタブに切り替えたときに、新しいタブとして(非アクティブ状態で)現れたという感じなのでしょうか?

    また空で表示されるのは、いつもこの「Berliner Philharmoniker – Symphonic Dances」というデータベースプレイリストなのでしょうか? 他のプレイリストでも発生しますか?

    #9710
    serenity
    参加者

    夜遅くすみません

    このトピックを投稿した時点ではこのBerliner Philharmoniker – Symphonic Dancesではなく複数の異なるタブで発生しました。しかしその後はしばらく発生せず、久しぶりに発生したのがこのBerliner Philharmoniker – Symphonic Dancesです

    >最初は表示されていなくて、他のタブに切り替えたときに、新しいタブとして(非アクティブ状態で)現れたという感じなのでしょうか?
    その通りです

    複数の異なるタブで発生したのはプレイリストがファイル化して以降とほぼ同時期で、Berliner Philharmoniker – Symphonic Dancesはそれ以前から時々起きていたように思います。何か元々異常があったのかもしれません。つまり同じ表示異常でも違う原因かもしれません

    また、私の記憶する限りではプレイリストを作成して曲を登録してないものはないはずです

    まとまりがなくてすみません

    不特定のタブでまた発生したら報告します

    #9711
    Chartreux
    参加者

    こんばんは。

    「Album Viewの設定」のタブ周りの設定を変更すると、今開いているプレイリスト以外全て空になりますね。変更した時にTuneBrowser全体を見ていると、表示周りを更新しているような動作をしているので、それが原因?と勝手に予想しています。

    serenityさんが仰っているように再起動かプレイリストを再読み込みで表示は復活します。解決に繋がれば幸いです。

    #9712
    Chartreux
    参加者

    追記です、「Album Viewの設定」の中の設定を変えた時に、表示周りを更新しているような挙動が出るものだと空になります。曲を再生していない場合でも起きますし、再生している場合はそういう挙動になる項目が増える感じですね。

    それと最近あまり弄っていないので覚えていないのですが、タブの名前 (Playback Queue、Library Viewer) やタブの水平、垂直マージンなどの設定が即座に反映されず、再起動後に反映されるのですが、この辺りは元々そうでしたっけ?

    Ver4.17.2.1555です。

    #9713
    serenity
    参加者

    Chartreuxさん、検証ありがとうございます。

    私の方でも再現しました。

    タブの設定ー詳細設定ータブの区切り線を強調するをYes-No-Yesとしてみました。

    こちらではタブ関連以外でもおかしくなります。(ヘッダ表示を最適化する を切換)

    (Attachments:参照)

     

    Attachments:
    #9715
    Tiki
    キーマスター

    Chartreuxさん、serenityさん、ありがとうございます。

    Chartreuxさんにご指摘いただいた方法で、おかげさまで問題を再現することができました。これがもともとserenityさんの言われていた問題と同じかどうか、確証が持てないのですが、再現できた問題については次のリリース時に改善したいと思います、

    次のリリースは、年内に先行版を… と思っています。

    #9763
    Tiki
    キーマスター

    こんにちわ。

    先ほど、4.17.3の先行版を公開しました. この問題に対処しています.

    先のコメントで「年内に先行版を」と言っていたのは、本当は4.18だったのですが、別トピックで急ぎめに対応したほうが良さそうな感じだったので、4.17.3を出すことにしました.

    #9765
    Chartreux
    参加者

    こんにちは。

    その他の原因で空になることがあるのかどうか分かりませんが、とりあえず設定を変更しても問題が起きなくなったのを確認しました。

    #9767
    serenity
    参加者

    Tikiさん、ありがとうございます。こちらでもVersion 4.17.3.1556でAlbum Viewの設定を変更後タブが空白にならないことを確認しました。

    #9772
    Tiki
    キーマスター

    さっそくのご確認、どうもありがとうございました。m(__)m

18件の投稿を表示中 - 1 - 18件目 (全18件中)
  • トピック「ビューに何も表示されないことがある」には新しい返信をつけることはできません。