4.9.0先行版でm4aの再生ができない

フォーラム TuneBrowser 4.9.0先行版でm4aの再生ができない

このトピックには13件の返信が含まれ、4人の参加者がいます。8 ヶ月、 3 週間前 Tiki さんが最後の更新を行いました。

14件の投稿を表示中 - 1 - 14件目 (全14件中)
  • 投稿者
    投稿
  • #5401

    serenity
    参加者

    4.9.0先行版で.m4aファイルの再生が出来ません。デバイスに対応していない旨のメッセージが表示されます。

    mp3,FLACなどは試していません。

    4.8.2では問題なく再生できます

    Windows10 1809 x64

    4.9.0 AVX2 x64

    音源:スタインバーグ UR12 wasapi

     

     

     

     

    #5402

    jin35y
    参加者

    同じくFLACやMP3が再生できないです。

    今は4.8.2に戻して使っています。

     

    #5403

    HAlk
    参加者

    失礼いたします。

    当方の場合、共有(SHAR)モードでmp3、FLACの再生ができません。

    排他(EXCL)モードの場合だと可能ですが不便です。

    #5410

    Tiki
    キーマスター

    こんばんわ。

    ご連絡ありがとうございます。皆さんWASAPIの共有モードでご利用でしょうか?

    #5411

    serenity
    参加者

    Tiki様

    私はwasapi排他モードで再生不可です。

    #5414

    Tiki
    キーマスター

    serenityさん。わかりました。ありがとうございます。

    次のコメントで、わかったことをまとめます。それに該当していないかどうか、もしおわかりになるようでしたらご確認いただけないでしょうか。

    #5415

    Tiki
    キーマスター

    共有モードで再生できない、というヒントで確認してみると、たしかに再生できなくなっているケースがありました。デバイス側のサンプルレートが楽曲側のサンプルレートに対応していない場合、既定の設定で自動的にデバイス側のサンプルレートに変換して再生するのですが、これがうまく動作していないことがわかりました。

    これは共有モード固有の問題ではありません。共有モードでそれが発生しやすいのは、ご周知の通り共有モードはデバイス側のサンプルレートが固定になり、たとえばそれが48kHzや96kHzに設定されていると、44.1kHzなどCD系のサンプルレートの曲は再生できなくなります。また一部のデバイスはクロックの関係で88.2kHzや176.4kHzの再生に対応していないことがありますので、リサンプラ―でx2などの設定をしているようなケースでも発生しやすくなります。

    これだけが原因とはかぎりませんが、いずれにしても、すこし対処に時間がかかりそうです。

    #5418

    jin35y
    参加者

    排他モードでResampleを使うと再生できますが、使わないと再生できなかったです。

    さらにいろいろ試してみたら、サウンドデバイスのコントロールパネルのサンプルレートの設定とTuneBrowserのサンプルレートが一致してないと再生できない事がわかりました。

    両方のサンプルレートの設定が44.1だとResampleでなくても再生できました。

    共有モードはまったくいろいろ設定を変えても再生できなかったです。

     

     

    #5419

    serenity
    参加者

    当方は排他モードでResampleを使っていますが再生出来ませんでした

    #5439

    Tiki
    キーマスター

    こんにちわ。

    先ほど4.9.0の先行版1439を公開しました。Resamplerを使用した場合に再生ができなくなることがある問題を改善しています。これがすべての事象の原因とはかぎらないのですが、お手数ですが一度お試しいただけると有り難いです。

    どうぞよろしくお願いします。

    #5442

    serenity
    参加者

    Tiki様

    4.9.0の先行版1439でm4a,FLAC,mp3がResamplerを使用、排他モードで再生できることを確認しました。ありがとうございました。

    #5443

    Tiki
    キーマスター

    こんにちわ。

    さっそくご確認いただき、ありがとうございました。お手数をおかけしました。

    #5463

    HAlk
    参加者

    当方でも問題なく再生できるようになりましたので、ご報告させていただきます。

    #5464

    Tiki
    キーマスター

    ご確認ありがとうございました。大丈夫そうですね。

14件の投稿を表示中 - 1 - 14件目 (全14件中)

トピック「4.9.0先行版でm4aの再生ができない」への新規返信追加は締め切られています。