RAMDecode再生時にテンポ遅くなる

フォーラム TuneBrowser RAMDecode再生時にテンポ遅くなる

  • このトピックには7件の返信、2人の参加者があり、最後にDonにより2年、 4ヶ月前に更新されました。
8件の投稿を表示中 - 1 - 8件目 (全8件中)
  • 投稿者
    投稿
  • #3324
    Don
    参加者

    お世話になっております。

    RAMDecode再生についてですが、アルバム数枚をランダム再生している時に、

    1時間ほど経つと曲のテンポが半分になり、途切れ途切れに再生されてしまいます。

    BitPerfectを厳密に設定していても再生が止まることはありません。

    そうなった場合、一度曲を止めて再生し直すと正常に戻ります。(エラーは吐きません)

    受け取り側のDACには正常なサンプリングレートとビット深度が表示されており、

    ロックが外れているわけではなさそうです。

    ASIO再生では今のところ発生しておらず、WASAPIの問題ではと思っています。

     

    急いでいませんので、お時間がある時に対応いただければ幸いです。

     

    ー再生環境

    OS:Windows10

    CPU:Corei7 970

    MEM:18GB

    DAC:Pioneer U-05 (USB接続)

    RAMDecodeノモード:自動

    RAMDecodeの並列処理:1

    自動判定時に「コンテンツごと」に移行する最大サイズ:4096

    RAMDecodeの最大メモリサイズ:8192

    バッファ時間:2000

    シーク後のバッファ時間:200

    #3326
    Tiki
    キーマスター

    こんばんわ。

    お気遣いいただいたように、すぐにはお応えできそうにない内容なのですが、取り急ぎ、RAMDecodeをオフにすると現象は発生しないのか、念のためにご確認いただけないでしょうか?

    #3327
    Don
    参加者

    Tiki様

     

    ご返信ありがとうございます。

    ご質問の件ですが、RAMDecodeをオフにすると問題は発生しません。

    ASIO再生ではASIOの特性上強制的に設定したビット深度でDACへ渡してしまう為、

    (DAC側のHiBit機能を使用しています)、現在はWASAPIのRAMDecodeオフで使用しています。

    数日この状態で聞いておりまして、件の不具合は発生しておりません。

     

    以上よろしくお願いします。

     

     

    #3339
    Tiki
    キーマスター

    こんにちわ。ご確認ありがとうございます。

    ご説明いただいた状況からはRAMDecodeに関係しそうなのですが、RAMDecodeは低レベルのファイルアクセス部分を抽象化してディスクの代わりにメモリから読むようにしているという仕掛けですので、デコード結果に変化を起こすような点はすぐには思いつきません。

    ひょっとしたら、提供されているデコーダ (の使い方) になにか問題があるのかもしれませんが…。

    ファイル形式になにか特徴はありますか? FLACやMP3など多種の形式で発生するのでしょうか、それとも特定のファイル形式で発生するような感じでしょうか?

    また、OpenHomeでのUPnP経由で再生とか、そういったなにか特徴はありませんか?

    #3340
    Don
    参加者

    早速のご返信ありがとうございます。

     

    フェイル形式ですが、FLACでもALACでも同様の症状が発生します。(圧縮音源は試していないので分かりません)

    再生環境ですが、音楽ライブラリをNASに保存し。そこから無線LANでファイルを取得しており、OpenHomeやDLNA、UPnPは使用していません。

     

    これは関係するか分かりませんが(というかもっともらしい理由を付けられませんが)、アルバム一枚単位の再生では今のところ症状は発生しません。

    アルバムを跨いで再生する場合、読み込むファイル容量が設定しているキャッシュ範囲内でも発生してしまいます。

    また、発生する場合は必ず曲の途中から発生し、曲の頭からテンポがおかしくなるような事はありません。

     

    以上よろしくお願いします。

    #3341
    Don
    参加者

    連投失礼します。

     

    先ほどRAMDecodeオフでも同様の症状が発生しました。

    RAMDecode再生の問題ではなくWASAPI再生の問題のようです。

    間違った情報を書き込んでしまい失礼しました。

    何分間欠症状ですので……

     

    #3343
    Tiki
    キーマスター

    こんばんわ。続報ありがとうございました。

    状況了解しました。ひとまず、RAMDecodeの問題ではなさそうですね。

    WASAPIでの再生の場合、おなじ排他モードでもPushでは問題ない、Eventではノイズが入る、あるいはその逆。などさまざまなケースがあります。またすくなくともわたしの環境では、あるモードでノイズが入る場合は、べつの再生ソフトでもノイズが入ります。

    対処療法としてなにかTuneBrowser側でできることはないか、ときおり調べているのですが、そればかりやっているわけにもいかず、現在のところは有用な対処方法は見つかっていません。

    よければ、Push/Eventなどのモードの切り替えもお試しになってください。

    #3349
    Don
    参加者

    こんにちは

     

    WASAPI排他モードPushで24時間以上連続再生していますが、上記不具合は発生しませんでした。

    Tiki様のおっしゃる通りEvent再生でのDAC(Pioneer U-05)との相性の可能性が高そうです。

    EventとPushの音の違いは聞き分けられなかったので、このまま使用していこうと思っています。

    ありがとうございました。

8件の投稿を表示中 - 1 - 8件目 (全8件中)
  • トピック「RAMDecode再生時にテンポ遅くなる」には新しい返信をつけることはできません。