Bluetooth接続のWASAPI (Exclusive mode) で再生が速くなる

フォーラム TuneBrowser Bluetooth接続のWASAPI (Exclusive mode) で再生が速くなる

  • このトピックには11件の返信、3人の参加者があり、最後にTikiにより1ヶ月、 2週前に更新されました。
12件の投稿を表示中 - 1 - 12件目 (全12件中)
  • 投稿者
    投稿
  • #12976
    Jahy
    参加者

    こんにちわ。

    TuneBrowser UWP 5.2.1(最新版)を使用しています。

    主にWASAPIを使用して聴いているのですが、ある時からヘッドホンのみWASAPI(Exclusive mode)の再生がおかしくなりました。

    現象は、再生速度が速くなる。というもので、ある日突然発症しました。

    WASAPI:ヘッドホン (2- ATH-WS990BT Stereo) (Exclusive mode) 速くなる。

    WASAPI:ヘッドホン (2- ATH-WS990BT Stereo) (Shared mode) 正常。

    WASAPI:スピーカー(SB Katana V2) (Exclusive mode) 正常。

    WASAPI:スピーカー(SB Katana V2) (Shared mode) 正常。

    このような状態です。ほとんど設定等は操作していません。

    最近ASIOドライバを抜いた、程度です。

    それと、TuneBrowser の設定を、全て初期状態に戻す方法はありますか?

     

    #12980
    Tiki
    キーマスター

    こんばんは。

    WASAPIではないのですが、わたしの環境ではあるASIO対応のデバイスが似たような状況になることがあります。他の家電類の動作が影響しているような感じであることから、電源変動が発生したときに、デバイスの状態とドライバの状態がかみ合わなくなるのだろうと想像しています。

    この事象が起きた場合は、再生を止めて、TuneBrowser(=ドライバを使用しているプロセス)を再起動などするとだいたい改善します。

    参考になればよいのですが。

    TuneBrowserの設定をすべて初期状態に戻したい場合は、アンインストールしてインストールするくらいでしょうか。

    #12981
    cosmer-k
    参加者

    横から失礼します

    私もBluetooth接続のヘッドホンなどを接続すると、WASAPI Exclusive modeで再生速度が早くなります。実は前バージョンからです。

    ソニーWH-1000XM3、DRC-BTN40

    Creative T12というスピーカー

    LOXJIE D30というBluetooth接続もできるUSBーDACなどで再生速度が早くなります。

    win11 22H2 64bit

    TuneBrowser は、AVX2 Versionです

    #12982
    Tiki
    キーマスター

    こんばんは。

    「前バージョンから」と言われているのは、5.1.6では現象は起きなくて、5.1.10では現象が発生する、ということでしょうか?

    #12983
    cosmer-k
    参加者

    >>「前バージョンから」と言われているのは、5.1.6では現象は起きなくて、5.1.10では現象が発生する、ということでしょうか?

    はい、そうです。5.1.6では普通に再生できてました。5.1.10からBluetoothでWASAPI(Exclusive mode)にすると再生速度が早くなります。

    #12984
    Tiki
    キーマスター

    ありがとうございます。

    5.1.6は、AVX2版ではありませんが、まだこちらで公開しています。このバージョンを使用すると、やはり事象は発生しないでしょうか? (すでにお試しいただいている場合は改めて試していただくには及びません。TuneBrowserのバージョンちがいが要因か、あるいは時間の経過によるドライバ類などの環境の変化による要因かを確認できれば、という意図です)

    また5.1.10ではかならず事象が発生するのでしょうか、あるいは発生するときがある、という感じでしょうか?

    #12985
    cosmer-k
    参加者

    いろいろ触っていたら、WASAPIデバイスのバッファ転送モードをEvent Modeに変更すると現象が発生しないことがわかりました。

    Bluetoothで、WASAPI(Exclusive mode)でPush Modeの時にのみ発生するようです。

    5.1.6をインストールしてみましたら WASAPI(Exclusive mode) Push Modeで発生しました

    5.1.6で発生していなかったと言うのは、思い違いだったようです(汗)

     

    5.1.10でもか必ず発生していました。

    #12986
    Tiki
    キーマスター

    ご確認ありがとうございました。

    あらためてバージョン間の変更箇所を確認していたのですが、やはりWASAPIに関する変更はなく、不思議に思っていたところでした。バージョンは関係なかったということですね。

    Event Modeでは発生しないことが確認できたとのこと、よかったです。デバイスによりこのEvent/Push Modeでうまく動作する/しないという事象はこれまでも確認しています。わたしの環境で改めて確認したところ、Bluetoothの場合、Push Modeではたしかに再生開始直後再生音がおかしくなるのですが、数秒で安定化します。このとき、TuneBrowserの動作としては正しいように見えますので、デバイスの特性だろうと思います。

    Jahyさん、もしEvent Modeをお試しでなければ、お試しください。

    #12987
    cosmer-k
    参加者

    Event/Push Modeでうまく動作する/しないという現象はこれまでにも有ったのですね。

     

    >>再生開始直後再生音がおかしくなるのですが、数秒で安定化します

    私の環境では、ずっと発生しています。これはパソコン、デバイスの環境に影響されているようですね。

    もやもやしていたのが解消された気分です(^_^;)

    ありがとうございました。

     

    Jahyさん よこからレスを付けてしまい失礼しました。

    #12988
    Jahy
    参加者

    こんにちわ。

    デフォルトがEventMode であるようですので、既にEventModeでした。

    一度インストールし直してみようと思います。

    #12989
    Jahy
    参加者

    こんにちわ。

    アンインストールして再びインストールしてみました。

    結果、問題は解消されました。

    結局何が原因かは掴めませんでしたが、とりあえず安定して聴くことができています。

    Tikiさん、cosmer-kさん、ありがとうございました。

    #12991
    Tiki
    キーマスター

    Jahyさん、ご連絡ありがとうございました。

    おっしゃるように何が問題だったかは不詳ですが、結果としてうまく動作するようになってよかったです。

    このトピックはここでクローズさせていただきます。

12件の投稿を表示中 - 1 - 12件目 (全12件中)
  • トピック「Bluetooth接続のWASAPI (Exclusive mode) で再生が速くなる」には新しい返信をつけることはできません。