曲の頭が切れて再生されてしまいます。

フォーラム TuneBrowser 曲の頭が切れて再生されてしまいます。

  • このトピックには30件の返信、3人の参加者があり、最後にTikiにより2年、 8ヶ月前に更新されました。
31件の投稿を表示中 - 1 - 31件目 (全31件中)
  • 投稿者
    投稿
  • #1279
    SCH
    参加者

    体感ですが0.2~0.3秒ほど始めが切れて再生されます、フェードは0で他の数値も変えてみましたが改善できなかったです。

    症状は単曲再生時のみで、ビットパーフェクト時と前曲からの移行時は頭からきちんと再生されます。

    Windows10homeでTuneBrowserは現在Free版です、他の方と質問が重複していたらすみません。

    #1284
    Tiki
    キーマスター

    SCHさん、こんばんわ。Tikiです。

    ご利用のTuneBrowserのバージョンはいくつでしょうか? 最近になって現れた症状でしょうか?

    また、楽曲の形式(MP3とかFLACとか)によって差はありますか?

    #1287
    SCH
    参加者

    症状は4.2.2と4.2.4で確認しております、昨年12月から使用させていただいておりますが初日からでした。

    形式はFLAC 24bit 96khzと16bit 44.1khz、AAC 44.1khzで同じ症状が確認できます、差はないように感じます。

    他の形式は使ってないので確認できておりません。

    #1288
    Tiki
    キーマスター

    ありがとうございます。

    音源に関係なく、また(見逃していましたが)BitPerfectの設定では発生しないとのことから、再生制御になにか問題があるのかもしれません。

    TuneBrowserは、最初のトラックの冒頭部以外からの再生の場合、フェードインで再生を開始するようになっています(この動作を切り替える設定は公開していなかったので、次のリリースでは設定で可否を切り替えられるようにします)。

    ただ、この設定は、フェード時間を0にすると効かなくなります。フェードの時間も0にされているとのことですので、そうなると、いまはすぐに思い当たるような点がありません。

    引き続きなにか関係するところはないか調べてみますが、もしなにかお気づきのことがあれば、教えていただけると有難いです。

    どうぞよろしくお願いします。

    #1289
    SCH
    参加者

    ありがとうございます、そこまで困る!という問題でもないですが自分も調べながら使っていきたいと思います。

    #1309
    Tiki
    キーマスター

    SCHさん、こんばんわ。Tikiです。

    先ほど、先行版の4.2.4.1345をアップしました。この版では、以前に書いた「次のリリースでは設定で可否を切り替えられるようにします」の部分に対応しています。

    設定画面の

    • 左側のツリー:「再生の設定」-「再生の詳細設定」
    • 右側の項目 :「詳細の設定」-「途中からの再生開始時にフェード処理する」

    ここが既定ではYesになっていますが、Noにして、いちど動作を見ていただけないでしょうか。

    お時間のあるときにでも、お試しいただければ有難いです。よろしくお願いします。

    #1310
    SCH
    参加者

    こんばんは、先ほど1345をDLしたのですが、セットアップを実行しようとするとWindows Defender SmartScreenに引っ掛かり実行できなかったです。

    1343では特に問題なくセットアップできたのですが…

    #1311
    Tiki
    キーマスター

    セットアップを実行しようとするとWindows Defender SmartScreenに引っ掛かり実行できなかったです。

    おそらく、ダウンロード数が少ないという理由で表示されているものだと思います。

    Windows 10であれば「詳細情報」と書かれている部分をクリックすると、実行ボタンが現れ、実行できるようになると思います。

    もし気になるようでしたら、UWP版のリリースをお待ちいただくしかないのですが…。

    #1313
    SCH
    参加者

    そういった条件で判定しているんですね、どうやらブロック設定になっていたようで警告のみにしました。

    「途中からの再生開始時にフェード処理する」を「NO」で再生したところ、Library Viewerで選択し再生(最初の投稿で単曲再生と書いた操作)すると症状に改善が見られました、FLACとAACで途切れずに再生できます。

    しかし、上部のPlayer Viewで戻る、進むボタンを押した場合に途切れて再生されています、やはり0.2~0.3秒でFLACとAACで出ております。

    #1315
    Tiki
    キーマスター

    SCHさん、ご確認いただき、ありがとうございました。

    「戻る、進むボタンを押した場合」について、(今夜はもう力尽きていますので(^^;)追って確認しておきます。

    #1318
    Tiki
    キーマスター

    SCHさん、こんばんわ。

    念のための確認なのですが、「戻る、進むボタンを押した場合」の頭かけは、フェードの設定を0msにされていますでしょうか?

    戻る、進むボタンを押すと現在再生中の音楽をフェードアウトして終了しますので、次の曲に移行した場合はフェードインから再生されます。つまり、「途中からの再生開始時にフェード処理する」の設定はこの場合は効きません。

    ご確認いただければ幸いです。

    #1328
    SCH
    参加者

    こんばんは、フェード時間はずっと0のままです。

    #1337
    Tiki
    キーマスター

    SCHさん、こんばんわ。

    わかりました、ありがとうございます。このトピックの最初のほうにも書いたのですが、本来はフェード時間を0に設定すると, DAC側の事情でないかぎり、頭欠けの事象は起きないはずです。それが設定変更やビットパーフェクトの設定で発生の有無が変わるというのは、なにか想定していない事象が発生している可能性はあるのですが、すいませんが、現在はまた思いつくところがありません。

    ちなみに、なのですが、「DAC側の事情」の場合は、再生開始時に自動的に無音データを送出する設定にすることで抑制することができます。わたしが知っている範囲では Chord の DAC はこの設定が必要です。

    #1348
    SCH
    参加者

    DACだとそういう設定もできるんですね、現在使用しているのが外付けサウンドカードの「Creative USB Sound Blaster HD r2」なのですが何かご存知でしょうか?

    #1353
    Tiki
    キーマスター

    すいませんが、その機種のことはわかりません。

    ちなみに、ですが、WASAPIでしょうか、ASIOでしょうか?

    最近のCreativeはASIOドライバも出していたと記憶していますので、別の方式で再生してみたらどうなるでしょうか?

    #1360
    SCH
    参加者

    いろいろ勉強になります、今までASIOで再生していましたが、WASAPIで再生したところ症状は出なかったです。

    #1362
    Tiki
    キーマスター

    なるほど、ASIOで発生していたということですね。

    すいませんがすぐの改善はむずかしそうなのですが、留意しておきます。

    #1392
    SCH
    参加者

    Tikiさんこんばんは。

    頭が途切れる症状の件ですがCREATIVE ASIOドライバのレイテンシー設定だったようです、デフォルト50msだったのを20ms以下にすることで途切れを感じなくなりました。

    ビットパーフェクト変更時、Library viewerでの選択再生、Player viewの戻る進むも問題なく再生できていると思います。

    以前MediaGo使用時に途切れはなかったのでアプリケーションの違いによるものかと思い込んでました、MediaGoはもうアンインストールしてしまったので再生設定の確認が出来ないのが悔しいです。

    ちなみにAVX2バージョンはUWPでリリース予定はありますか?

    #1393
    Tiki
    キーマスター

    SCHさん、こんばんわ。

    ご確認いただき、どうもありがとうございました。レイテンシの設定で頭かけが発生するというのは、もうひとつ原理がわかりませんが(^^;、とにかくよかったです。

    UWP版は、残念ながらストアのしくみ上CPUの世代は指定できないので(64bit/32bitのアーキテクチャは指定できます)、AVX2版のリリースはできないです。ご了承ください。

    よろしくお願いします。

     

    #1397
    SCH
    参加者

    わかりました、では配布版のライセンス取得します。

    レイテンシーの数値を上げていくと連動するように頭かけの範囲も広くなったので、何かしら関連はあるとは思いますが解決を見たということで、ありがとうございました。

    #1622
    ponta
    参加者

    わたくしも同じような症状で悩んでおりまして、FLACファイルを連続して再生すると問題なく頭から再生されるのですが、WAVEファイルを再生したあと、別のFLACファイルを再生すると、質問者様がおっしゃられるように頭が欠けて再生されてしまいます。もしくは、TuneBrowserを起動して初めにFLACファイルを再生させるとやはり同じ症状です。WASAPIにて再生しているのですが、レイテンシーの値を上下させることで改善されるとのことなのですが、その設定方法などがわからず困っております。Realtek Digital Output を使用しているのですが、もしレイテンシーの設定方法などでアドバイスいただけましたら、お願いしたいと思っております。

    #1623
    Tiki
    キーマスター

    pontaさん、こんにちわ。

    このトピックで議論されたような内容は、お試しになられたのでしょうか?

    #1624
    ponta
    参加者

    Tikiさま お世話になります。
    途中からの再生開始時にフェード処理する を無効にしたり、フェードの設定を0ms にしたりと一応、書かれていることはやってみましたが、まったく変わらずで 2018-01-17 20:35 に書かれていることが気になりまして
    『CREATIVE ASIOドライバのレイテンシー設定だったようです、デフォルト50msだったのを20ms以下にすること』 これをどの箇所でやるのかが、わからず質問をさせていただいた次第であります。

    #1625
    ponta
    参加者

    PCとAVアンプを光ケーブルでつないでいるのですが、もしかしたら、これはTuneBrowserが原因ではなくAVアンプの仕様なのかもしれませんね。TuneBrowserの方ではイコライザーは反応しているので、音だけが欠けている感じなのですが・・・。最後の頼みの綱という感じでレイテンシーにすがってみたいと思った次第であります。

    #1626
    Tiki
    キーマスター

    こんばんわ。お試しになられた状況は わかりました。ありがとうございます。

    もしDAC側の事情でしたら、以下の設定で抑制できるかもしれません。

    設定画面の

    • 左側のツリー:「再生の設定」-「再生の詳細設定」
    • 右側の項目 :「自動無音再生」-「方式の切替り時」-「再生開始時にはいつも実施」

    ここをYesにしていただくと、再生開始時に、その上の項目にある無音再生時間分、無音データを送出します。

    一度お試しください。

    #1627
    Tiki
    キーマスター

    補足です。

    もしDAC側が、何らかの理由(省電力など)で、無音でないデータをトリガにして動作を開始するような場合は、残念ながらこのやり方は効かないことになります。アクディブスピーカー系で、そのような動作をするものを見たことがあります。

    #1629
    ponta
    参加者

    Tikiさま お世話になります。
    「自動無音再生」-「方式の切替り時」-「再生開始時にはいつも実施」をYESに設定しても全く変わらずという感じです。ご指摘にあるDAC側の理由で無音でないデータをトリガにして動作を開始しているっぽいですね。一度、USBスピーカーを購入してその辺りを回避した環境での動作を行いたいと思っております。もしその環境で同じ症状の場合、お手数ではございますが、もう一度ご相談に乗っていただければ幸いでございます。お時間を取らせてしまい申し訳ございませんでした。

    #1630
    ponta
    参加者

    Tikiさま お世話になります。

    古いUSBスピーカーのWASAPI再生で何も問題なく音が欠けることがなく再生できました。まさか音楽再生の為に購入したAVアンプが原因だったとは・・・。貴重なお時間を消費させてしまい大変申し訳ございませんでした。取り急ぎご連絡まで。

    #1637
    Tiki
    キーマスター

    ご確認ありがとうございました。

    AVアンプのケースは、先に例に挙げたChordと同様、ユーザの意図しない操作などで破裂的な音が出ないように、という考慮なのではないかと推察します。Chordの場合は、あらかじめ無音を送ることで回避できましたが…。

    #1647
    ponta
    参加者

    Tikiさま 大変お世話になります。

    無音再生でとりあえず1000ミリ設定で無事、頭からの再生ができました。これからどこまで短くして再生できるかのポイントを探そうと思っております。このソフトのライセンスを購入して改めてよかったと思いました。これからのご活躍を祈念いたします。ありがとうございました。

    #1653
    Tiki
    キーマスター

    念のため、の細かい話ですが、ここで応対させていただいているのは、ライセンスを購入していただいたからではありません (ライセンスはサポート費ではありません。もし何らかの尺度でサポート費を定めたとしたら、いまのライセンス体系ではまったくまかなえないと思います)。

    ただ、ライセンスを購入していただいた方がおられなかったら、まちがいなくTuneBrowserの開発はここまで来れていなかったと思いますので、大変感謝しています > ALL m(__)m

31件の投稿を表示中 - 1 - 31件目 (全31件中)
  • トピック「曲の頭が切れて再生されてしまいます。」には新しい返信をつけることはできません。