v4.18.0 のASIO初期化について

フォーラム TuneBrowser v4.18.0 のASIO初期化について

  • このトピックには5件の返信、3人の参加者があり、最後にshimazumにより1ヶ月前に更新されました。
6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • 投稿者
    投稿
  • #10401
    jtakayan
    参加者

    お世話になっております。

    先日v4.18.0 のAVX版にアップデートしたのですが、またもASIOドライバの初期化に失敗します。

    —-以下エラー情報—-

    2021/03/11 08:20:01,813.305: 2021/03/11 08:20:01,813.304: T0333c: TL08: Stage: [InitializePlayer]
    2021/03/11 08:20:01,813.337: 2021/03/11 08:20:01,813.336: T0333c: TL08: Player module [ASIO: Sony Headphone Amplifier Driver] initialized.
    2021/03/11 08:20:01,813.383: 2021/03/11 08:20:01,813.381: T0475c: TL08: Stage: [InitializeDevice]
    2021/03/11 08:20:01,814.243: 2021/03/11 08:20:01,814.241: T0475c: TL08: Creating ASIOProxyProcess.
    2021/03/11 08:20:01,817.360: 2021/03/11 08:20:01,817.358: T0475c: TL08: Creating ASIOProxyProcess completed.
    2021/03/11 08:20:01,828.727: 2021/03/11 08:20:01,828.726: T0475c: TL08: ASIOProxyProcess: Call : [Initialize] Param:0
    2021/03/11 08:20:02,887.688: 2021/03/11 08:20:02,887.685: T0475c: TL08: Error: ASIOProxyProcess: Detected ProcessDead by ExitCode -1073740791.
    2021/03/11 08:20:02,887.700: 2021/03/11 08:20:02,887.699: T0475c: TL08: ASIOProxyProcess: Done : [Initialize] Result:0 Wait:0
    2021/03/11 08:20:02,887.718: 2021/03/11 08:20:02,887.717: T0475c: TL08: Error: Initialize ASIO driver failed. End device.
    2021/03/11 08:20:02,887.737: 2021/03/11 08:20:02,887.735: T0475c: TL08: ASIOProxyProcess: Call : [End] Param:0
    2021/03/11 08:20:02,917.927: 2021/03/11 08:20:02,917.925: T0475c: TL08: Error: ASIOProxyProcess: Detected ProcessDead by ExitCode -1073740791.
    2021/03/11 08:20:02,917.938: 2021/03/11 08:20:02,917.936: T0475c: TL08: ASIOProxyProcess: Done : [End] Result:0 Wait:0
    2021/03/11 08:20:02,917.963: 2021/03/11 08:20:02,917.962: T0475c: TL08: ASIOProxyProcess: Call : [Quit] Param:0
    2021/03/11 08:20:02,948.181: 2021/03/11 08:20:02,948.179: T0475c: TL08: Error: ASIOProxyProcess: Detected ProcessDead by ExitCode -1073740791.
    2021/03/11 08:20:02,948.189: 2021/03/11 08:20:02,948.188: T0475c: TL08: ASIOProxyProcess: Done : [Quit] Result:0 Wait:0
    2021/03/11 08:20:02,948.199: 2021/03/11 08:20:02,948.198: T0475c: TL08: Error: Quit ASIOProxyProcess failed.
    2021/03/11 08:20:02,948.211: 2021/03/11 08:20:02,948.210: T0475c: TL08: Terminating for ASIOProxyProcess by 100 ms.
    2021/03/11 08:20:02,948.283: 2021/03/11 08:20:02,948.282: T0475c: TL08: Terminating for ASIOProxyProcess completed.
    2021/03/11 08:20:02,948.606: 2021/03/11 08:20:02,948.605: T0475c: TL08: Error: InitializeDevice result: NG
    2021/03/11 08:20:02,948.645: 2021/03/11 08:20:02,948.643: T0333c: TL08: Error: Player device [ASIO: Sony Headphone Amplifier Driver] initialize failed.
    2021/03/11 08:20:02,949.070: 2021/03/11 08:20:02,949.068: T0333c: TL08: Error: デバイスの初期化に失敗しました.

    —- 以上エラー情報 —-

    私が持つ全てのASIOデバイスで上記の初期化エラーが出たのでデバイスの問題ではないと判断しています。
    以前にもご報告させていただきましたが、やはりウイルスバスタークラウド(17.0.1257)が悪さをしているようで、ウイルスバスタークラウドの例外設定に「C:\Program Files\TuneBrowser\TBASIOHelperW.exe」を追加したところ、初期化に成功し、正常に再生することが出来ました。

    ひとまず、同じような境遇の方がいるかもしれないので、僭越ながらご報告させていただきます。

    以上です。

    #10402
    jtakayan
    参加者

    >例外設定に「C:\Program Files\TuneBrowser\TBASIOHelperW.exe」を追加したところ

    厳密には

    • C:\Program Files\TuneBrowser
    • C:\Program Files\TuneBrowser\TBASIOHelperW.exe

    の2つです(TBASIOHelperW.exeだけだとTuneBrowser自体が起動しないことがあります)

    #10406
    Tiki
    キーマスター

    こんばんわ。情報ありがとうございます。

    毎々のことながら、ちょっと心が折れそうになりますね(^^;。

    #10413
    jtakayan
    参加者

    お世話になります。

    他のASIO対応プレイヤーは未確認なにでわからないのですが、ウイルスバスターは時折「なんでこれ?」というプログラムをブロックすることがちょいちょいあります。

    まあ、より高い安全性を担保するためには仕方のないことなのかもしれません(先日ウイルスバスタークラウドは重大なセキュリティホールが見つかったとかで不具合修正したばかりなので、そのせいかもしれませんね)。

    こういうのは結局いたちごっこになりますので、作者様が対策なさる必要はないと個人的には考えています。
    セキュリティ対策ソフト側にログが全くでないので、詳しくない人はここが原因とたどり着くことは困難でしょうが、そこは利用に際し、その注意喚起をしていただくだけで良いと思います。

    TuneBrowserは安全なソフトウェアであるということを、私自身の自己責任の元ウイルスバスターの例外設定に追加して問題なく動いておりますので、私はこのチケットをもって改修を希望しておりません(告知なりの対策を打っていただいてクローズで良いと思います)

    #10414
    Tiki
    キーマスター

    コメントありがとうございます。

    このような事象に関する説明は、じつはこちらのページで告知を行っています。一般的に書いていますので、ご指摘いただいたような具体的な方法は書いていませんが…。またあまり前向きな話でもないので、このサイトのいちばん下のところからリンクできるようにしています。

    今回、ここで書いてくださったことで、また多くの方の目に触れるようになったと思いますので、またこのまま様子を見たいと思います。ありがとうございました。

    #10430
    shimazum
    参加者

    ありがとうございます。
    3/13にv4.17.3からv4.18.0をインストールしましたがtunebrowserの起動ができたりできなかったり、
    起動しても再生しようとすると「デバイスの初期化に失敗しました」の表示で動かず。
    v4.17.3に戻して起動再生が無事にできほっとしました。
    v4.18.0は様子を見ようと思っていたらこのトピックをみつけました。
    v4.18.0の再インストール、ウイルスバスタークラウドの例外設定で無事解決しました。

6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • トピック「v4.18.0 のASIO初期化について」には新しい返信をつけることはできません。